Defender™ USB3.0 Secure Encrypted External Drives (HDDs and SSDs) not recognized on computers running Windows 8.1 & Windows 10 when connected by USB3.0
Kanguru Part Numbers Affected by this advisory:
- KDH3B-500
- KDH3B-1T
- KDH3B-1.5T
- KDH3B-2T
- KDH3B-256SSD
- KDH3B-480SSD
- KDH3B-300F-500
- KDH3B-300F-1T
- KDH3B-300F-1.5T
- KDH3B-300F-2T
- KDH3B-300F-256S
- KDH3B-300F-480S
Host Environment(s) applicable:
Windows 8.1 computers with Intel based controller chipsets
Windows 10 computers with Intel based controller chipsets
Symptom(s):
- The CD-ROM partition is not detected or is detected but is not accessible on an affected Host Environment.
Cause(s):
- The detection failure for the Kanguru HDD/SSD is because of a faulty Microsoft xHCI (eXtensible Host Controller Interface) driver stack provided out-of-the-box with Windows 8.1 & Windows 10
Solution(s):
Update your Windows operating system to the latest versions. Microsoft released a cumulative update for Windows 8.1 and Windows 10 on July 12, 2016 which resolves this issue (KB3163912).
Comments
0 comments
Article is closed for comments.